
 
 

1 

 
 

Dokumentacja zestawu 
startowego CanSat Kit 

 

 

 

 

 

 

 

Rewizja dokumentu: v1.5 (2020-10-26) 

Dotyczy zestawu CanSat Kit rev. 1.2 

  



 
2 

1 Spis treści 
 

2 Przeznaczenie zestawu ................................................................................................................................. 4 

3 Elementy zestawu ........................................................................................................................................ 4 

4 Parametry techniczne .................................................................................................................................. 5 

4.1 Płytka główna CanSata / stacji naziemnej .......................................................................................... 5 

4.1.1 Informacje ogólne ........................................................................................................................... 5 

4.1.2 Mapa złącz, gniazd i diod LED ......................................................................................................... 6 

4.1.3 Źródła i metody zasilania płytki .................................................................................................... 14 

4.1.4 Układ zasilania ............................................................................................................................... 15 

4.1.5 Mikrokontroler .............................................................................................................................. 16 

4.1.6 Czytnik kart microSD ..................................................................................................................... 17 

4.1.7 Moduł radiowy .............................................................................................................................. 17 

4.1.8 Parametry mechaniczne ................................................................................................................ 18 

4.2 Czujnik temperatury .......................................................................................................................... 20 

4.2.1 Parametry pomiarowe .................................................................................................................. 20 

4.2.2 Zasilanie ......................................................................................................................................... 20 

4.2.3 Interfejs .......................................................................................................................................... 20 

4.2.4 Pinout ............................................................................................................................................. 20 

4.2.5 Parametry mechaniczne ................................................................................................................ 21 

4.3 Czujnik ciśnienia atmosferycznego ................................................................................................... 21 

4.3.1 Parametry pomiarowe .................................................................................................................. 21 

4.3.2 Zasilanie ......................................................................................................................................... 22 

4.3.3 Interfejs .......................................................................................................................................... 22 

4.3.4 Pinout ............................................................................................................................................. 22 

4.3.5 Parametry mechaniczne ................................................................................................................ 22 

5 Uruchomienie zestawu .............................................................................................................................. 23 

5.1 Instalacja i konfiguracja środowiska Arduino IDE ............................................................................ 23 

5.2 Podłączanie płytki do komputera za pomocą portu USB ................................................................. 27 

5.3 Wgranie pierwszego programu „Hello CanSat” ............................................................................... 28 

5.4 Podłączenie i testy czujnika temperatury ......................................................................................... 30 

5.5 Podłączenie i testy czujnika ciśnienia ............................................................................................... 31 



 
3 

5.6 Używanie karty micro SD .................................................................................................................. 32 

5.7 Używanie modułu radiowego ........................................................................................................... 34 

5.7.1 Konfiguracja nadajnika .................................................................................................................. 34 

5.7.2 Konfiguracja odbiornika ................................................................................................................ 35 

5.8 Podłączenie anten ............................................................................................................................. 36 

6 Zestaw analogiczny .................................................................................................................................... 37 

6.1 Lista elementów zestawu analogicznego ......................................................................................... 37 

6.2 Podłączenie modułów ....................................................................................................................... 38 

6.3 Różnice i ograniczenia ....................................................................................................................... 38 

7 Bezpieczeństwo i zasady prawidłowego użytkowania ............................................................................. 39 

 

  



 
4 

2  Przeznaczenie zestawu 
 

Zestaw startowy CanSat Kit zaprojektowany został jako platforma do budowy minisatelity CanSat 

oraz stacji naziemnej zgodnych z wymaganiami konkursu „CanSats in Europe” oraz polskich 

zawodów CanSat organizowanych przez ESERO-PL. 

     

Przed użyciem zestawu należy zapoznać się z niniejszym dokumentem, 
w szczególności z rozdziałem 7. Bezpieczeństwo i zasady prawidłowego użytkowania. 

 

3 Elementy zestawu 

 

Zestaw zawiera wszystkie niezbędne komponenty elektroniczne do wypełnienia misji 

podstawowej minisatelity CanSat: moduł zasilania (bez akumulatora/baterii), komputer 

pokładowy, moduły łączności bezprzewodowej, a także czujniki temperatury i ciśnienia 

atmosferycznego.  

Obudowa minisatelity CanSat, system odzysku (np. spadochron) oraz akumulator/bateria 

zasilająca powinny zostać wykonane/dodane przez użytkownika zestawu według wymagań 

danego minisatelity. 

 

Zestaw CanSat Kit składa się z następujących elementów: 

• 2 x płytka główna CanSata / stacji naziemnej 

• 1 x płytka drukowana prototypowa 

• 1 x czujnik temperatury LM35 

• 1 x czujnik ciśnienia BMP280 

• 2 x kabel mini USB 

• 1 x złącze antenowe SMA 

• 1 x listwa kołkowa 2x40-pin 2.54 mm 

• 2 x złącze śrubowe typu terminal block 2.54 mm 

• 1 x płytka stykowa 
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• 8 x kabel do płytki stykowej 

• 1 x opakowanie ESD 

4 Parametry techniczne 
 

4.1 Płytka główna CanSata / stacji naziemnej 
 

 

 

4.1.1 Informacje ogólne 
 

Płytka główna dedykowana jest do użycia zarówno w minisatelicie CanSat, jak i w stacji naziemnej 

do odbioru danych drogą radiową. 

Płytka główna składa się z następujących bloków: 
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• układ zasilania – umożliwia zasilenie płytki i urządzeń zewnętrznych z pojedynczego 

ogniwa baterii litowo-jonowej lub innych ogniw o napięciach 2.5 – 5.0 V; 

• komputer pokładowy – mikrokontroler zgodny z Arduino M0, z możliwością 

programowania przez port USB; 

• magazyn danych – złączę na kartę microSD, dostępne z poziomu komputera 

pokładowego; 

• moduł łączności bezprzewodowej – układ radiowy nadawczo-odbiorczy, oparty o 

standard LoRa, z zewnętrznym złączem antenowym. 

 

4.1.2 Mapa złącz, gniazd i diod LED 
 

 
Tabela 1. Złącza, gniazda i diody LED płytki głównej / stacji naziemnej 
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Nazwa złącza Opis i funkcje 

BAT (J4) 

• złącze zasilania zewnętrznego (np. z baterii): 2.5 – 5.0 V, 

• raster 2.5 mm,  

• możliwość wlutowania złącza typu listwa kołkowa (header), 

śrubowego (terminal block) lub przylutowania przewodów (ze stress 

reliefem). 

RBL (J3) 
• zworka zasilania, 

• możliwość wpięcia głównego włącznika, 

mini USB (J5) 

• zasilanie, 

• programowanie mikrokontrolera z Arduino IDE, 

• przesyłanie danych (SerialUSB), 

• po więcej szczegółów zobacz dokumentację Arduino M0 dotyczącą 

złącza USB. 

J1, J2 

• złącze kołkowe żeńskie 2.5 mm, 

• dostępne napięcia zasilające, 

• wyprowadzone wejścia/wyjścia mikrokontrolera. 

micro SD 
• złącze na karty pamięci micro SD, 

• podłączone do mikrokontrolera – zob. 4.1.6. 

ANT 

• złącze anteny modułu radiowego, 

• możliwość przylutowania złącza SMA np. do wkręcenia większej 

anteny (w stacji naziemnej), 

• możliwość przylutowania anteny ćwierćfalowej wykonanej z 

przewodu. 

 

  

https://cdn.sparkfun.com/assets/5/3/b/f/2/526d7970757b7f7f708b4568.jpg
https://cdn.sparkfun.com/assets/5/3/b/f/2/526d7970757b7f7f708b4568.jpg
https://media.rs-online.com/t_large/F6163422-01.jpg
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4.1.2.1 Złącze J1 

 

🛈 

Piny zaznaczone (✓) jako „Arduino M0” są w pełni kompatybilne z płytką Arduino M0. 
Szczegółowe informacje o właściwościach i wykorzystaniu tych pinów są dostępne 
w dokumentacji Arduino M0: https://store.arduino.cc/arduino-m0 

  

     

Standard napięć dla pinów mikrokontrolera to 3.3 V.  
Podłączenie urządzeń pracujących w innych standardach napięciowych (np. 5 V) 
może skutkować uszkodzeniem zestawu. 

 

 

 

 

https://store.arduino.cc/arduino-m0
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Tabela 2. Mapa pinów złącza J1 

Pin nr Nazwa 
Arduino 

M0 
Opis 

Użycie w Arduino IDE 

wejście / 
wyjście 
cyfrowe 

wejście 
analogowe 

wyście 
analogowe 

inne funkcje 

1 +5 V  Zasilanie + 5 V - - - - 

2 +5 V  Zasilanie + 5 V - - - - 

3 SCL2 ✓ Interfejs I2C – linia SCL (clock) 17 - - I2C – Wire lib 

4 SDA2 ✓ Interfejs I2C – linia SDA (data) 16 - - I2C – Wire lib 

5 SWCLK  
pin do programowania przy użyciu 
zewnętrznego programatora 

- - - - 

6 SWDIO  
pin do programowania przy użyciu 
zewnętrznego programatora 

- - - - 

7 D1 ✓ 

Generalnego przeznaczenia – 
wejście/wyjście cyfrowe (GPIO) 
Serial port TX: w Arduino IDE jako 
Serial1 

1 - - Serial1 (TX) 

8 D0 ✓ 

Generalnego przeznaczenia – 
wejście/wyjście cyfrowe (GPIO) 
Serial port RX: w Arduino IDE jako 
Serial1 

0 - - Serial1 (RX) 

9 D3 ✓ 
Generalnego przeznaczenia – 
wejście/wyjście cyfrowe (GPIO) 

3 - 3 - 

10 D2 ✓ 
Generalnego przeznaczenia – 
wejście/wyjście cyfrowe (GPIO) 

2 - 2 - 

https://www.arduino.cc/reference/en/language/functions/digital-io/digitalread/
https://www.arduino.cc/reference/en/language/functions/digital-io/digitalwrite/
https://www.arduino.cc/reference/en/language/functions/analog-io/analogread/
https://www.arduino.cc/reference/en/language/functions/analog-io/analogread/
https://www.arduino.cc/reference/en/language/functions/analog-io/analogwrite/
https://www.arduino.cc/reference/en/language/functions/analog-io/analogwrite/
https://www.arduino.cc/en/Reference/Wire
https://www.arduino.cc/en/Reference/Wire
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11 D5 ✓ 
Generalnego przeznaczenia – 
wejście/wyjście cyfrowe (GPIO) 

5 - 5 - 

12 D4 ✓ 
Generalnego przeznaczenia – 
wejście/wyjście cyfrowe (GPIO) 

4 - 4 - 

13 A1 ✓ 
Wejście/wyjście cyfrowe (GPIO), wejście 
analogowe (ADC) 

A1 A1 - - 

14 A0 ✓ 

Wejście/wyjście cyfrowe (GPIO), wejście 
analogowe (ADC), wyjście analogowe 
(DAC) 

A0 A0 A0 - 

15 A3 ✓ 
Wejście/wyjście cyfrowe (GPIO), wejście 
analogowe (ADC) 

A3 A3 - - 

16 A2 ✓ 
Wejście/wyjście cyfrowe (GPIO), wejście 
analogowe (ADC) 

A2 A2 - - 

17 A5 ✓ 
Wejście/wyjście cyfrowe (GPIO), wejście 
analogowe (ADC) 

A5 A5 - - 

18 A4 ✓ 
Wejście/wyjście cyfrowe (GPIO), wejście 
analogowe (ADC) 

A4 A4 - - 

19 AREFA ✓ 
Zewnętrzne napięcie referencyjne dla 
przetwornika ADC (opcjonalnie) 

- - - - 

20 GND ✓ Masa - - - - 

 

https://blog.arduino.cc/2010/12/13/tutorial-arduino-and-the-aref-pin/
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4.1.2.2 Złącze J2 
 

🛈 

Piny zaznaczone (✓) jako „Arduino M0” są w pełni kompatybilne z płytką Arduino M0. 
Szczegółowe informacje o właściwościach i wykorzystaniu tych pinów są dostępne 
w dokumentacji Arduino M0: https://store.arduino.cc/arduino-m0 
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Tabela 3. Mapa pinów złącza J2 

Pin nr Nazwa 
Arduino 

M0 
Opis 

Użycie w Arduino IDE 

wejście / 
wyjście 
cyfrowe 

wejście 
analogowe 

wyście 
analogowe 

inne funkcje 

1 +3.3 V  Zasilanie + 3.3 V - - - - 

2 +3.3 V  Zasilanie + 3.3 V - - - - 

3 nRESET ✓ 

Zanegowany reset mikrokontrolera 
(zwarcie z GND powoduje reset 
mikrokontrolera) 

- - - - 

4 Vbat  Napięcie z wejścia Vbat (za zworką RBL) - - - - 

5 SERIAL5_RXD ✓1 
Dodatkowy Serial port RX: w Arduino IDE 
jako Serial 

- - - Serial (RX) 

6 SERIAL5_TXD ✓1 
Dodatkowy Serial port TX: w Arduino IDE 
jako Serial 

- - - Serial (TX) 

7 D6 ✓ 
Generalnego przeznaczenia – 
wejście/wyjście cyfrowe (GPIO) 

6 - - - 

8 D7 ✓ 
Generalnego przeznaczenia – 
wejście/wyjście cyfrowe (GPIO) 

7 - - - 

9 D8 ✓ 
Generalnego przeznaczenia – 
wejście/wyjście cyfrowe (GPIO) 

8 - - - 

10 D9 ✓ 
Generalnego przeznaczenia – 
wejście/wyjście cyfrowe (GPIO) 

9 - - - 

11 D13 ✓ 

Generalnego przeznaczenia – 
wejście/wyjście cyfrowe (GPIO), 
podłączona dioda D13 

13 - - - 

https://www.arduino.cc/reference/en/language/functions/digital-io/digitalread/
https://www.arduino.cc/reference/en/language/functions/digital-io/digitalwrite/
https://www.arduino.cc/reference/en/language/functions/analog-io/analogread/
https://www.arduino.cc/reference/en/language/functions/analog-io/analogread/
https://www.arduino.cc/reference/en/language/functions/analog-io/analogwrite/
https://www.arduino.cc/reference/en/language/functions/analog-io/analogwrite/
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12 MISO2 ✓ 
Interfejs SPI, podłączony czytnik kart SD 
oraz moduł radiowy 

18 - - - 

13 SCK2 ✓ 
Interfejs SPI, podłączony czytnik kart SD 
oraz moduł radiowy 

20 - - - 

14 MOSI2 ✓ 
Interfejs SPI, podłączony czytnik kart SD 
oraz moduł radiowy 

21 - - - 

15 GND ✓ Masa - - - - 

16 GND ✓ Masa - - - - 

 

Przypisy: 

1 – dostępne na Arduino M0 w wersji Wemos SAMD21 M0 

2 – do linii podłączono rezystor podciągający do 3.3 V (pull-up) o rezystancji 15 k 

 

 

 

https://startingelectronics.org/articles/arduino/wemos-arduino-m0/
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4.1.2.3 Diody 
 

Tabela 4. Diody świecące (LED) dostępne na płytce i ich funkcje 

Nazwa diody Opis 

LED D13 

• dioda LED bezpośrednio podłączona do pinu D13 mikrokontrolera, 

• kompatybilna z diodą D13 w Arduino M0 (LED_BUILTIN), 

• po więcej szczegółów zobacz dokumentację Arduino M0. 

LED PWR 

• dioda sygnalizująca obecność napięcia na linii zasilania 3.3 V, 

• obecność napięcia na linii 3.3 V implikuje obecność na linii 5 V (oraz 

VBAT, jeśli zasilanie jest dostarczane przez VBAT). 

LED RX 
• aktywna, gdy płytka odbiera dane przez port SerialUSB (więcej 

szczegółów w dokumentacji Arduino M0) 

LED TX 
• aktywna, gdy płytka wysyła dane przez port SerialUSB (więcej 

szczegółów w dokumentacji Arduino M0) 

 

4.1.3 Źródła i metody zasilania płytki 
 

Płytka główna może być zasilana na kilka różnych sposobów, które zostały przedstawione poniżej: 

1) Złącze zasilające J4 (BAT) 

̶ minimalne napięcie wejściowe: 2.5 V 

̶ maksymalne napięcie wejściowe: 5.0 V 

̶ zasilenie układów płytki ze złącza BAT następuje tylko wtedy, gdy zwarta jest zworka 

oznaczona jako RBL, 

̶ zalecane jest zasilanie płytki z akumulatorów litowo-jonowych (1 cela szeregowo/1S, 3.7 - 

4.3 V), baterii lub akumulatorów 3 x AA/AAA połączone szeregowo (3.6 – 4.5 V). 

 

2) Złącze mini USB (J5) 

̶ maksymalne napięcie wejściowe: 5.5 V 

̶ podłączenie płytki za pomocą złącza mini USB spowoduje zasilenie jej modułów (w tym 

pojawienie się napięcia na liniach zasilających 5 V i 3.3 V na złączu J1 i J2) niezależnie od 

stanu zworki RBL. 

 

3) Złącze kołkowe J2: VBAT (pin 4) oraz GND (piny 15 lub 16) 

̶ minimalne napięcie wejściowe: 2.5 V 
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̶ maksymalne napięcie wejściowe: 5.0 V 

̶ podłączenie płytki za pomocą tego złącza spowoduje zasilenie jej modułów (w tym 

pojawienie się napięcia na liniach zasilających 5 V i 3.3 V na złączu J1 i J2) niezależnie od 

stanu zworki RBL. 

     
Zamiana polaryzacji zasilania powoduje nieodwracalne uszkodzenia na płytce!   

 

     

Podłączenie napięcia większego niż maksymalne napięcie podane w specyfikacji dla 
danego wejścia może spowodować nieodwracalne uszkodzenia na płytce!    

 

 

4.1.4 Układ zasilania 
 

Układ zasilania obecny na płytce odpowiada za konwersję energii elektrycznej, dystrybucję na 

płytce głównej do zasilania jej podzespołów oraz dostarczenie energii do zasilenia układów 

dołączanych do płytki głównej przez użytkownika. 

Układ dostarcza następujące linie zasilania na złączach J1 i J2: 

• linia 5 V 

− napięcie (minimalne, nominalne, maksymalne): 4.7 V, 5.0 V, 5.4 V 

− wydajność prądowa: maksymalnie 0.75 A, zalecana 0.5 A 

 

• linia 3.3 V 

− napięcie (minimalne, maksymalne): 3.0 V, 3.3 V 

− wydajność prądowa: maksymalnie 0.75 A, zalecana 0.5 A 

 

• linia VBAT 

− bezpośrednie, niezabezpieczone napięcie z baterii (za zworką RBL). 

 

     
Sumaryczny pobór prądu z linii 3.3 V i 5 V nie może przekraczać 1 A. 
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W przypadku poboru większego prądu niż podano w specyfikacji dla danej linii, 
zostanie aktywowane zabezpieczenie nadprądowe, które skutkuje odłączeniem linii 
na pewien okres. Cała płytka powinna zostać odłączona od zasilania na kilka minut, 
aby przywrócić napięcie na odłączonej linii. Zabezpieczenie prądowe jest 
realizowane za pomocą bezpieczników typu „polyfuse”. 

 

Zworka RBL 

Zworka RBL jest podłączona szeregowo ze pinem „+” złącza BAT (J4). Zalecane jest podłączenie 

przełącznika do złącza RBL (J3), który będzie pełnił funkcję głównego włącznika CanSata. Jeśli 

przełącznik jest zlokalizowany w innym miejscu, złącze RBL (J3) można zewrzeć na stałe. 

 

     

Zworka ma wpływ tylko i wyłącznie za odłączanie/włączanie źródła zasilania 
podpiętego do złącza BAT (J4). Nie ma ona wpływu, jeśli płytka zasilana jest przez 
złącze miniUSB (J5) oraz przez pin VBAT na złączu J2! 

 

 

4.1.5 Mikrokontroler 
 

Adel ATSAMD21G18 to wydajny, 32-bitowy mikrokontroler z rdzeniem ARM Cortex® M0. 

W 100% zgodny z Arduino M0.  

Parametry techniczne: 

Mikrokontroler ATSAMD21G18, LQFP 48 

Architektura rdzenia ARM Cortex-M0+ 

Napięcie pracy 3.3V 

Pamięć Flash 256 KB 

Pamięć SRAM 32 KB 

Częstotliwość zegara 48 MHz 
 

Dostępne dla użytkownika interfejsy zostały wymienione w tabelach 4.1.2.1 oraz 4.1.2.2. 

 

     

Pobór prądu z każdego pinu mikrokontrolera: 

• maksymalnie 10 mA 

• rekomendowane 7 mA   
 

https://store.arduino.cc/arduino-m0
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Sumaryczny pobór prądu z pinów w obrębie jednej grupy zasilania maksymalnie 
65 mA.  Zobacz dokumentację mikrokontrolera. 

 

     

Sumaryczny pobór prądu ze wszystkich pinów mikrokontrolera maksymalnie 
130 mA. Zobacz dokumentację mikrokontrolera. 

 

 

4.1.6 Czytnik kart microSD 
 

Czytnik kart microSD został podłączony do mikrokontrolera poprzez interfejs SPI, zgodnie z 

poniższą tabelą. 

Pin karty SD (funkcja w trybie SPI karty SD) Pin mikrokontrolera 

DAT0 (MISO) MISO 

CMD (MOSI) MOSI 

CLK (Clock / SCK) SCK 

DAT3 (Chip Select / CS) D11 
 

🛈 

Więcej informacji o podłączaniu karty SD do Arduino można znaleźć 
w dokumentacji biblioteki oraz poradniku. 

 

4.1.7 Moduł radiowy 
 

Moduł radiowy SX1278 został podłączony do mikrokontrolera poprzez interfejs SPI oraz 

dodatkowe piny GPIO, zgodnie z poniższą tabelą: 

 

Pin modułu SX1278 Pin mikrokontrolera 

MISO MISO 

MOSI MOSI 

SCK SCK 

NSS D10 

RESET nRESET 

https://www.microchip.com/wwwproducts/en/ATSAMD21G18
https://www.microchip.com/wwwproducts/en/ATSAMD21G18
https://www.arduino.cc/en/Reference/SD
https://www.arduino.cc/en/Reference/SDCardNotes
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DIO0 D12 

DIO1 D91 
 

 

Przypisy: 

1 – domyślnie pin DIO1 nie jest podłączony do pinu mikrokontrolera D9, aby to zrobić należy 

wlutować rezystor R10 - wielkość SMD0603 o wartości 0 - 100  lub zworkę np. kawałek drutu. 

Nie jest to jednak niezbędne do wykonania misji CanSata, instrukcja przez cały czas zakłada, że 

pin jest odłączony.  

🛈 

Szczegółowe informacje o module radiowym SX1278 można znaleźć w jego 
dokumentacji. 

 

4.1.8 Parametry mechaniczne 
 

Kształt płytki: koło o promieniu 30 mm ze ściętymi fragmentami – w miejscu ścięcia szerokość 

54.4 mm. 

Na płytce rozmieszczone są 4 otwory montażowe przeznaczone na śruby M3 (średnica 3.2 mm). 

Otwory posiadają metalizowane obręcze (średnica 6.5 mm), podłączone bezpośrednio do masy 

(GND). 

https://cdn-shop.adafruit.com/product-files/3179/sx1276_77_78_79.pdf
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Masy poszczególnych elementów zestawu zebrane są w tabeli: 

Element Masa 

Płytka główna 18 g 

Płytka prototypowa + złącza goldpin 10 g 

Czujnik ciśnienia 1 g 
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4.2 Czujnik temperatury 

🛈 

Szczegółowe informacje o czujniku temperatury LM35 można znaleźć w jego 
dokumentacji. 

  

4.2.1 Parametry pomiarowe 
 

• 0.5 °C dokładności (w temperaturze 25 °C) 

• Dostosowany do zakresu temperatur −55 °C to 150 °C 

• Niskie samoogrzewanie (self-heating), 0.08 °C w stojącym powietrzu 

• Nielinowość pomiaru ±¼ °C (typowo) 

 

4.2.2 Zasilanie 
 

• zakres napięcia zasilania: 4 V – 20 V  

• pobór prądu: 60 μA 

 

4.2.3 Interfejs 
 

LM35 jest czujnikiem analogowym. Informacja o mierzonej temperaturze zakodowana jest 

w postaci napięcia wyjściowego obecnego na pinie nr 2 czujnika, zgodnie z równaniem: 

𝑉𝑜𝑢𝑡 = 𝑇 [℃] ⋅ 10 [𝑚𝑉/℃] 

gdzie 𝑇 [℃] jest mierzoną temperaturą. 

 

4.2.4 Pinout 
 

Poniższy obrazek pokazuje identyfikację pinów czujnika LM35: 

http://www.ti.com/lit/ds/symlink/lm35.pdf
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1. VCC 

2. OUT 

3. GND 

 

4.2.5 Parametry mechaniczne 
 

Czujnik posiada obudowę plastikową typu TO-92 z trzema wyprowadzeniami. Przybliżone 

wymiary czujnika przedstawione są w dokumentacji obudowy TO-92 (strony 29-30). 

 

4.3 Czujnik ciśnienia atmosferycznego 

🛈 

Szczegółowe informacje o czujniku ciśnienia atmosferycznego BMP280 można 
znaleźć w jego dokumentacji. 

 

4.3.1 Parametry pomiarowe 
 

• Zakres pomiaru ciśnienia: 300 - 1100 hPa 

• Zakres pomiaru temperatury: od –40 - 85 °C 

• Dokładność bezwzględna (0 - 65 °C): ±1 hPa 

• Dokładność względna (700 – 900 hPa przy +25 °C do +40 °C): ± 0.12 hPa (odpowiada 

±1 m) 

• Czas pomiaru: od 5.5 ms 

 

http://www.ti.com/lit/ds/symlink/lm35.pdf
https://www.bosch-sensortec.com/products/environmental-sensors/pressure-sensors/pressure-sensors-bmp280-1.html
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4.3.2 Zasilanie 
 

• zakres napięcia zasilania: 1.71 V – 3.6 V  

• pobór prądu: < 1 mA 

 

4.3.3 Interfejs 
 

• komunikacja z mikrokontrolerem poprzez cyfrowy interfejs I2C (linie SDA i SCL) 

• adres I2C czujnika: 0x76 

• zarówno mikrokontroler, jak i czujnik na swojej płytce posiadają odpowiednie rezystory 

podciągające linie SDA i SCL (pull-up), wymagane do prawidłowej pracy interfejsu I2C 

• alternatywnie możliwość użycia interfejsu SPI – szczegóły dostępne w dokumentacji 

czujnika 

 

4.3.4 Pinout 
 

Pogrubione skróty obecne są na spodniej stronie płytki czujnika: 

• VCC - Napięcie zasilania 3.3 V 

• GND - Masa 

• SCL - Zegar I2C / SPI 

• SDA - Linia danych I2C / MOSI w trybie SPI 

• CSB - Chip Select (standardowo nieużywany, nieprzylutowany) 

• SD0 - MISO w trybie SPI (standardowo nieużywany, nieprzylutowany) 

 

4.3.5 Parametry mechaniczne 
 

• Czujnik jest przylutowany do niewielkiej płytki PCB ze złączem w postaci listwy kołkowej 

6-pin o rastrze 2.54 mm. 

• Dostępne są również dwa otwory montażowe o średnicy 3 mm. 

• Rozmiar płytki: 15 x 10 mm 

• Masa: 0.6 g 
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5 Uruchomienie zestawu 
 

5.1 Instalacja i konfiguracja środowiska Arduino IDE 
 

1) Pobierz program Arduino IDE w wersji desktop przynajmniej 1.8.5 ze strony 

https://www.arduino.cc/en/main/software dla swojego systemu operacyjnego. 

2) Zainstaluj oprogramowanie zgodnie z instrukcjami dla swojego systemu operacyjnego: 

https://www.arduino.cc/en/Guide/HomePage . 

3) Uruchom Arduino IDE i przejdź do opcji: „Tools → Board: … → Boards Manager…”. 

 

 

4) W oknie „Boards Manager” wyszukaj “SAMD” i zainstaluj paczkę „Arduino SAMD Boards (32-

bits ARM Cortex-M0+)” w najnowszej wersji i zamknij okno.  

 

 

https://www.arduino.cc/en/main/software
https://www.arduino.cc/en/Guide/HomePage
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5) Po zainstalowaniu pakietu płytek Arduino SAMD należy wybrać rodzaj płytki, która będzie 

używana – w menu „Tools → Board → Arduino M0”. 
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6) Przejdź do zakładki „Sketch → Include Library → Manage Libraries…” i wyszukaj bibliotekę 

„CanSat Kit Library”, a następnie kliknij „Install”. 

 

 



 
26 

 

 

Po chwili biblioteka powinna być oznaczona jako zainstalowana: 

 

Porada: warto sprawdzać co jakiś czas czy dostępne są aktualizacje bibliotek (z poziomu 

menedżera bibliotek). 

 

7) W menu „File → Examples → CanSat Kit Library” dostępne są przykładowe programy. 

 



 
27 

 

 

5.2 Podłączanie płytki do komputera za pomocą portu USB 
 

1) Używając kabla mini USB dołączonego do zestawu podłącz jedną z płytek głównych CanSat 

Kit do komputera PC. 

2) W menu „Tools → Port” powinna być widoczna płytka Arduino M0 pod nazwą „COMx 

(Arduino M0)”. Po wybraniu tego portu możliwe będzie programowanie i komunikacja 

z podłączoną płytką. 
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5.3 Wgranie pierwszego programu „Hello CanSat” 
 

1) Otwórz przykładowy program „File → Examples → CanSatKit → HelloCanSatKit” 

2) Upewnij się, że płytka jest podłączona do komputera, a Arduino IDE ustawione jest zgodnie 

z punktami 5.1 5) oraz 5.2. 

3) Po wciśnięciu przycisku „Upload” (na pierwszym rysunku poniżej) rozpocznie się kompilacja 

i wgrywanie oprogramowania na płytkę (drugi rysunek): 
 

 
 

 
 

Proces wgrywania jest sygnalizowany przez miganie niebieskiej diody D13. 
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4) Po zakończeniu wgrywania (jak na rysunku poniżej) nowy program jest wykonywany przez 

płytkę CanSat Kit. 

 

 
 

5) Ostatnim krokiem jest weryfikacja działania programu. 

̶ Dioda LED D13 powinna migać co 1 sekundę. 

̶ Po otwarciu Monitora Portu Szeregowego (Serial Monitor): „Tools → Serial Monitor” lub 

ikona lupy w prawym, górnym rogu Arduino IDE na ekranie powinny wyświetlać się 

komunikaty przesyłane do komputera przez płytkę CanSat Kit.  

Uwaga! Należy upewnić się, że wybrana jest prędkość „115200 baud” – jak pokazano na 

obrazku poniżej: 

 

 

 

Uwaga! Po wgraniu oprogramowania może zmienić się numer portu COM – aby otworzyć 

„Serial Monitor” może okazać się konieczne ponowne wybranie portu - patrz 5.2 pkt. 2). 

Wynik działania programu jest widoczny na obrazku poniżej: 
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5.4 Podłączenie i testy czujnika temperatury 
 

1) Podłącz czujnik temperatury do płytki CanSat Kit w następujący sposób: 

 

Piny płytki CanSat Kit Piny czujnika LM35 

+5 V (1) Vcc 

A0 (2) OUT 

GND (3) GND 

 

2) Otwórz przykładowy program „File → Examples → CanSatKit → TemperatureSensor” i wgraj 

go na płytkę. 

3) Po otwarciu Monitora Portu Szeregowego (Serial Monitor) na ekranie wyświetlone zostaną 

pomiary temperatury. Alternatywnie można otworzyć aplikację „Kreślarka”: „Tools → Serial 

Plotter” (lub kombinacja klawiszy Ctrl-Shift-L). 
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5.5 Podłączenie i testy czujnika ciśnienia 
 

1) Podłącz czujnik ciśnienia do płytki CanSat Kit w następujący sposób: 

 

Piny płytki CanSat Kit Piny czujnika ciśnienia BMP280 

+3.3 V VCC 

GND GND 

SCL SCL 

SDA SDA 

 

2) Otwórz przykładowy program „File → Examples → CanSatKit → PressureSensor” i wgraj go 

na płytkę. 

3) Po otwarciu Monitora Portu Szeregowego (Serial Monitor) na ekranie wyświetlone zostaną 

pomiary ciśnienia. Alternatywnie można otworzyć aplikację „Kreślarka”: „Tools → Serial 

Plotter” (lub kombinacja klawiszy Ctrl-Shift-L). 
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5.6 Używanie karty micro SD 
 

Do uruchomienia tego przykładu konieczne będzie włożenie karty pamięci micro SD do 

odpowiedniego slotu na płytce. Polecane jest używanie kart o niewielkich rozmiarach 

np. 128 MB – 8 GB. 

1) Włóż kartę micro SD do slotu na płytce (stykami karty SD do płytki), podłącz płytkę kablem 

USB do komputera. 

2) W środowisku Arduino IDE otwórz przykład Datalogger: „File → Examples → SD → 

Datalogger”. 
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3) Dokonaj niezbędnych modyfikacji w programie: 

̶ stałą const int chipSelect = 4; zamień na const int chipSelect = 11; 

̶ wszystkie wystąpienia wyrazu Serial zamień na SerialUSB. 

4) Skompiluj i wgraj program na płytkę. 

5) Otwórz monitor portu szeregowego i obserwuj dane które powinny być zapisane na kartę SD 

(program wyświetla i zapisuje wartości z trzech wejść analogowych do których można 

podłączyć np. czujnik LM35). W przypadku błędów inicjalizacji karty SD lub błędów zapisu 

stosowne informacje będą również wyświetlone. 

6) Po pewnym czasie (kilku minutach) odłącz płytkę od zasilania, wysuń kartę ze slotu i włóż do 

czytnika w swoim komputerze PC. Odczytaj zawartość pliku z danymi i sprawdź, czy są one 

poprawne. 
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5.7 Używanie modułu radiowego 
 

Do tego przykładu potrzebne będą dwie płytki CanSat Kit – jedna będzie pełniła rolę nadajnika 

(CanSat), a druga odbiornika (stacja naziemna). 

 

5.7.1 Konfiguracja nadajnika 
 

1) Otwórz przykładowy program „File → Examples → CanSatKit → 

RadioTransmitHelloCanSat” i wgraj go na płytkę. 

2) Otwórz monitor portu szeregowego, zaobserwuj pojawiające się komunikaty – porównaj 

z poniższymi:  

 

 
 

3) Zaobserwuj miganie diody D13 – sygnalizuje to poprawną pracę nadajnika. 
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5.7.2 Konfiguracja odbiornika 
 

Następnie należy uruchomić odbiornik radiowy na drugiej płytce. 

1) Podłącz drugą płytkę do komputera. 

2) Wybierz port COM odpowiadający drugiej płytce. 

3) Otwórz przykładowy program „File → Examples → CanSatKit → RadioReceiver” i wgraj go 

na płytkę. 

4) Otwórz monitor portu szeregowego, zaobserwuj pojawiające się komunikaty – oznaczają 

one odebrane pakiety: 

 

 

 

5) Parametr RSSI (Receiver Signal Strength Indicator) wskazuje siłę sygnału w odbiorniku. 

Zaobserwuj jak zbliżanie i oddalanie płytek wpływa na wartość RSSI. 
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5.8 Podłączenie anten 
 

🛈 

Krótkodystansowa komunikacja np. podczas testów oprogramowania może odbywać 
się bez anten. 

 

Polecaną anteną do płytki umieszczonej w minisatelicie CanSat jest ćwierćfalowa antena 

monopolowa wykonana z giętkiego przewodu typu linka/drut o długości około 14 cm. Taka 

antena może być przylutowana bezpośrednio do środkowego pola lutowniczego oznaczonego 

CN1/ANT: 

 

Przewód należy zabezpieczyć przez ułamaniem w miejscu lutowania – należy zrobić tzw. „stress 

relief” za pomocą np. kleju epoksydowego lub na gorąco. 

Do płytki stacji naziemnej przewidziane jest złącze SMA, które należy wlutować w miejsce 

CN1/ANT w następujący sposób:  

Miejsce na przylutowanie 

przewodu / anteny 

https://i.stack.imgur.com/vnF6U.jpg
https://i.stack.imgur.com/vnF6U.jpg
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Do takiego złącza można przyłączyć większą antenę np. typu Yagi-Uda za pomocą kabla 

koncentrycznego 50 Ω. 

 

6 Zestaw analogiczny 

 

Zestaw CanSat Kit można odtworzyć przy użyciu ogólnodostępnych komponentów i modułów 

elektronicznych. Prototypowanie, eksperymenty i testy, które mogą spowodować przypadkowe 

uszkodzenie zestawu CanSat Kit poleca się przeprowadzać na zestawie analogicznym. 

6.1 Lista elementów zestawu analogicznego 
 

• Arduino M0 (lub odpowiednik np. Wemos SAMD21 M0) x 2 

• Moduł radiowy SX1278 x 2 

• Moduł czytnika kart SD x 2 

• Moduł czujnika ciśnienia BMP280 x 1 

• Czujnik LM35 x 1 

• Płytka stykowa x 2 

• Kable połączeniowe do płytki stykowej i modułów 
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6.2 Podłączenie modułów 
 

Moduł radiowy należy podłączyć do Arduino M0 zgodnie z rozdziałem 4.1.7 Moduł radiowy, 

natomiast czytnik kart micro SD zgodnie z rozdziałem 4.1.6 Czytnik kart microSD. W obu 

przypadkach należy pamiętać o podłączeniu zasilania zgodnie z wymaganiami zakupionych 

modułów. Czujniki LM35 i BMP280 należy podłączyć w identyczny sposób jak do płytki głównej 

CanSat Kit. 

 

6.3 Różnice i ograniczenia 
 

     

Zestaw analogiczny dostarcza takie same poziomy napięć jak zestaw CanSat Kit 
(3.3 V, 5 V), jednakże wydajność prądowa poszczególnych linii zasilania może być 
inna, w zależności od zakupionej wersji Arduino M0 lub jego odpowiednika. 

 

     

Zestaw analogiczny nie może być zasilany z baterii/akumulatorów o takim samym 
napięciu jak zestaw CanSat Kit. 

 

     

Po pomyślnych testach na zestawie analogicznym należy przeprowadzić testy na 
zestawie CanSat Kit! 

 

     

Testy zasięgu radiowego powinny być prowadzone na zestawie CanSat Kit ze 
względu na duży wpływ toru radiowego i anten na osiągi. 
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7 Bezpieczeństwo i zasady prawidłowego użytkowania 
 

1) Zestaw przeznaczony jest do celów edukacyjnych, badawczych i rozwojowych. 

2) Użycie zestawu na zewnątrz wymaga zastosowania obudów chroniących przed wilgocią, 

bezpośrednim kontaktem z wodą, zanieczyszczeniami i pyłem. 

3) Zestaw powinien być zasilany zgodnie z instrukcjami zawartymi w niniejszym dokumencie. 

Nieprawidłowe podłączenie zestawu może doprowadzić do jego uszkodzenia i komponentów 

podłączonych do zestawu, silnego nagrzania elementów, wzniecenia otwartego ognia, a nawet 

eksplozji akumulatorów (jeśli były podłączone). 

4) Zewnętrzne urządzenia elektroniczne powinny być podłączone do zestawu przez dedykowane 

do tego złącza wymienione w rozdziale 4.1.2 Mapa złącz, gniazd i diod LED. Podłączanie, 

lutowanie czy wprowadzanie innych modyfikacji do zestawu skutkuje utratą gwarancji i może 

doprowadzić do uszkodzenia zestawu. Należy przestrzegać ograniczeń odnośnie użytkowania 

wyprowadzeń zestawu i podłączania urządzeń zewnętrznych, które są wymienione w niniejszej 

instrukcji. 

5) Zestaw jest czuły na wyładowania elektrostatyczne ESD, które mogą doprowadzić do 

uszkodzenia części lub całości urządzenia. Zaleca się stosować procedury zmniejszające ryzyko 

powstawania wyładowań elektrostatycznych (maty, opaski uziemiające itp.). 

6) Zestaw nie powinien być użytkowany w przypadku stwierdzenia widocznego uszkodzenia 

jakiejkolwiek jego części do czasu zweryfikowania wpływu zaistniałego uszkodzenia lub 

naprawienia usterki. 

7) W przypadku stwierdzenia nadmiernego nagrzewania się elementów zestawu, podejrzanego 

zapachu, pojawienia się dymu lub ognia należy natychmiast odłączyć cały zestaw od wszelkich 

źródeł zasilania. 

8) Elementy zestawu należy czyścić za pomocą suchej lub nasączonej alkoholem izopropylowym 

antystatycznej ściereczki. Wyjątek stanowi czujnik ciśnienia BMP280, który może być 

czyszczony tylko ściereczką suchą. 

9) Zużyte elementy zestawu powinny zostać zutylizowane zgodnie z obowiązującym prawem, 

w szczególności nie mogą być wyrzucane wraz z odpadami ogólnymi. 
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